Segui Corsi Excel Roma sui Social Corsi Excel Roma profilo Google+ Corsi Excel Roma profilo LinkedIn Corsi Excel Roma profilo Facebook

HomeExcel Analisi dei dati

Gestione degli errori

Excel Gestione degli errori nelle formule

Un argomento che, volente o nolente, “appassiona” coloro che lavorano di frequente con Excel è la gestione degli errori che possono risultare nell’esecuzione di una formula o funzione.
Crediamo che valga la pena dedicare qualche riga sulla gestione degli errori per indicare le principali soluzioni da adottare, dalle più semplici alle più “complesse”.
Innanzitutto vale la pena di elencare gli errori principali che un utente può fronteggiare durante l’esecuzione di formule o funzioni più complesse.
I più comuni, che trattiamo in questa newsletter, sono: #NOME?, #N/D, #RIF! e #VALORE!.
L’errore #NOME? può avere varie spiegazioni:

• Quando si digita un nome di funzione errato: ad esempio CERCA.VERA invece di CERCA.VERT.

• Quando vengono omesse le doppie virgolette in una stringa di testo all’interno di una funzione: ad esempio =SE(C2>=300;ottimo) dove la parola ottimo che deve risultare nella cella va messa tra virgolette.

• Quando si usa all’interno di una funzione un nome cella ma non esiste alcuna cella alla quale è stato assegnato quel nome: ad esempio =B2*iva ma a nessuna cella è stato dato il nome Iva.

L’errore #N/D indica che un valore non è disponibile per la funzione.
Spesso si tratta di un falso errore (per così dire) perché può risultare da un CERCA.VERT con corrispondenza esatta che non trova ciò che viene cercato.
Non si tratta di una funzione errata ma di un errore possibile nel risultato della funzione.
L’errore #RIF! occorre quando in una formula o funzione si fa riferimento ad una cella che non è possibile trovare.
L’errore è comunque quando si elimina una cella che era argomento di una funzione.
L’errore #VALORE! Indica che si sta usato un valore errato all’interno della formula, ad esempio si sta cercando di fare un’operazione di calcolo tra due celle (ad esempio addizione) una delle quali contiene testo.
Una volta fatto questo elenco delle principali cause di errore, bisogna distinguere tra gli errori che si possono correggere e quelli che invece non vanno corretti, come nel caso del CERCA.VERT con risultato #N/D perché, soprattutto sui file dinamici, quello che oggi è un risultato di errore domani potrebbe essere validato dalla presenza del valore al momento non trovato.
In questo caso, però, sarebbe preferibile che non apparisse il valore di errore nella cella e ci sono varie soluzioni per farlo, anche in base alla finalità che si vuole perseguire.

STAMPA SENZA ERRORI

Se lo scopo è semplicemente non visualizzare gli errori sulla pagina stampata, allora è sufficiente dare una impostazione che non stampi l’errore.
Si agisce dalla linguetta FOGLIO della finestra di dialogo IMPOSTA PAGINA (attivare la scheda LAYOUT e poi cliccare sulla piccola freccia a destra del gruppo di comandi IMPOSTA PAGINA).
Nella sezione “Stampa - Errori cella come” decidere come vanno visualizzati gli errori. Nell’immagine l’opzione impostata è che stampa la cella come se fosse vuota.


FORMATTAZIONE DELLE CELLE CON ERRORI

Un altro “escamotage” è quello di formattare le celle che contengono errori con un colore che funzioni come uno … sbiancatore.
In altre parole, l’errore permane nella cella ma non è visibile.
Dopo aver selezionato la cella o le celle, si va sulla scheda HOME, poi FORMATTAZIONE CONDIZIONALE e si clicca su NUOVA REGOLA.
Nella finestra (vedi immagine sotto) si clicca su FORMATTA SOLO LE CELLE CHE CONTENGONO e nella sezione inferiore FORMATTA SOLO CELLE CON si sceglie Errori.
A quel punto si preme il pulsante FORMATO per definire la formattazione.
Chiaramente o si darà un colore carattere simile al colore di riempimento o viceversa, per fare in modo che l’errore ci sia ma non si veda.



La terza soluzione è la più “scientifica” e la più completa. Prevede che nelle celle contenenti risultati di errore, sia mostrato un valore impostato dall’utente o la cella rimanga vuota.
Questo accade grazie alla funzione SE.ERRORE che intercetta il possibile errore e personalizza il messaggio.
Il funzionamento è semplice: si imposta come prima la funzione SE.ERRORE e poi si specificano i suoi due argomenti:

• Il primo argomento (denominato VALORE) è il riferimento alla cella o funzione che potrebbe contenere errore. Nel 99% dei casi si agirà nella stessa cella che ospita la funzione (infatti, a differenza di altre funzioni, SE.ERRORE può essere immessa nella stessa cella e non in celle a fianco). Quindi, come argomento si nidificherà nel SE.ERRORE la funzione che si vuole eseguire. L’esempio classico è il CERCA.VERT.

• Il secondo argomento (denominato VALORE_SE_ERRORE) è la specifica ci cosa deve apparire nelle celle in luogo dell’errore. Può essere un valore (es. 0), un testo (es. “prodotto non trovato”) un valore di vuoto (“”) ma anche un’altra formula o funzione.

Per fare un esempio, la funzione = SE.ERRORE(CERCA.VERT(A2;Fatturato!$A$1:$C$43;3;0);"Codice errato o inesistente") nell’esempio sotto raffigurato, immette il testo “Codice errato o inesistente” nelle celle in cui la funzione CERCA.VERT non trova il contenuto della cella A2 (il codice cliente) nella tabella presente nell’intervallo celle A1:C43 di un foglio denominato “Fatturato”. Siccome due codici non vengono trovati, al posto dell’errore #N/D viene digitato il testo già menzionato, il che rende anche più leggibile la funzione stessa.



Se l'articolo è stato utile, seguici sui Social networks cliccando i pulsanti in alto a destra di questa pagina.

Se vuoi condividere questo articolo nella tua Rete sociale, puoi utilizzare i bottoni Social a sinistra